[Dudas]: ¿Cómo mantener actualizado nuestro LMDE?

LMDE está diseñada para ser una distribución Rolling Release, usando siempre los repositorios Testing de Debian, pero tenemos que tener en cuenta varios aspectos para que esto se cumpla. Una duda que han planteado muchos usuarios, tanto acá en el blog, como en los foros de LinuxMint, es que no saben que rama de Debian usar con LMDE.

Trataré de explicar más o menos de forma sencilla de que va esto. LMDE salió cuando aún Squeeze era la rama testing de Debian, pero ahora la rama testing es Wheezy.

¿Qué pasa si nos quedamos con Squeeze?

Por ahora nada, ya que esto no influye, pero recuerden que LMDE además del repositorio de Debian, usa un repositorio propio con paquetes de Linux Mint y ahí es donde puede existir el problema.

Dicho repositorio se actualiza y puede darse el caso, que alguna dependencia no se cumpla con unos de los paquetes (atrasados) de Squeeze. Además, al usar Squeeze estaremos usando la versión Stable de Debian, donde las actualizaciones son menores y casi nulas, por lo que no se estaría cumpliendo el efecto Rolling Release.

¿Que debo hacer para que LMDE sea Rolling Release?

Sencillo. Primero modificamos nuestro sources.list.

$ sudo nano /etc/apt/sources.list

Por defecto, LMDE trae (o debe traer) en nuestro fichero sources.list las siguientes entradas:

deb http://packages.linuxmint.com/ debian main
deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free

Donde Testing pudo haber sido reemplazado por Squeeze. Si es el caso reemplazan Squeeze por Wheezy o lo dejan tal y como lo muestro más arriba.

Otra cosa que debemos hacer, si instalamos desde Synaptic, es ir a Preferencia (Settings) » Distribución (Distribution) » Preferir versión de (Prefer versions from): y escoger Testing.

De esta forma, cuando actualizemos, el sistema instalará primero las versiones más altas desde el repositorio de Debian y podremos obtener paquetes como LibreOffice 3.3.1, Pidgin 2.7.11 o actualizar el motor Gtk murrine.

¿Cual es el riesgo que sufro al usar LMDE de esta forma?

Sencillamente es muy probable que ninguno. Los paquetes que entran a la rama de testing de Debian son bastante estables, por lo que no tenemos que preocuparnos por eso.

Conclusiones.

Al usar en nuestro source.list los repos de testing, la próxima vez que Debian cambie a una versión superior, no sentiremos la diferencia :D y siempre tendremos nuestro sistema actualizado y completamente funcional.

Cualquier duda que tengan, me lo dejan en los comentarios y la iré añadiendo al artículo. :D

About these ads

Acerca de elav

Melómano, Informático y amante de GNU/Linux, el Software Libre y la Tecnología en general. Administrador de Red por profesión y Blogger por hobbie.

Publicado el 17 marzo, 2011 en Dudas, Linux Mint, LMDE y etiquetado en , , , , . Guarda el enlace permanente. 31 comentarios.

  1. Luis Alberto

    ahora si todo entendido perfectamente :p

    gracias por aclarar este royo para algunos que todavia no nos manejamos muy bien en esto :D

    suerte y sigue asi con el blog que esta excelente

  2. Gracias por el aporte.

  3. Buenos dias.

    Alguien podria indicar como actualizar la version de Firefox en LMDE la version que trae en la 3.6.13 y ya va por la 3.6.15

    Gracias,

  4. Yo no entendía la declaración:

    “Testes que podem ter sido substituído por Squeeze. Se assim for substituir Squeeze por Wheezy ou deixá-lo como mostro acima.”

    ¿Podría dar un ejemplo?

  5. Hola! Gracias por la informacion, me aclaraste mis dudas pero me surgieron otras: se puede eliminar o comentar (#)el repositorio de mint? y la otra es: afectaria gravemente al sistema?
    De antemano gracias!

    • Por poder, se puede. Solo te pasarán dos cosas:

      1- Sin el repo de Mint no usarías LMDE, sino Debian.
      2- Puede que algún paquete ya instalado en LMDE necesite de ese repositorio, por lo que pasa a ser local u obsoleto..

      ¿Que interés tendrías en comentar el repo de Mint?

      • Pues interes… mmm ninguno en especial, solo me surgio la duda y me la respondi a medias pues pense en tu respuesta 2 y no pense jamas en la 1.
        Ok muchas gracias por tu pronta respuesta, me has sido de gran ayuda, Un saludo!

  6. Saludos desde Puerto Rico

    Gracias por toda la ayuda

    tengo un problema con LMDE, Lo e intentado usar pero siempre me da el mismo problema y es al momento de actualizar. me devuelve este error.

    Errors were encountered while processing:
    udev
    rsyslog
    cups
    cups-pdf
    upower
    gdm3
    hplip-cups
    mintsystem
    pcscd
    plymouth
    plymouth-drm
    plymouth-themes-fade-in
    plymouth-themes-glow
    plymouth-themes-script
    plymouth-themes-solar
    plymouth-themes-spinfinity
    plymouth-themes-all
    x11-common
    xserver-common
    xserver-xephyr
    xserver-xorg-core
    xserver-xorg-video-voodoo
    xserver-xorg-video-vmware
    xserver-xorg-video-vesa
    xserver-xorg-video-tseng
    xserver-xorg-video-trident
    xserver-xorg-video-tdfx
    xserver-xorg-video-sisusb
    xserver-xorg-video-sis
    xserver-xorg-video-siliconmotion
    xserver-xorg-video-savage
    xserver-xorg-video-s3virge
    xserver-xorg-video-s3
    xserver-xorg-video-rendition
    xserver-xorg-video-r128
    xserver-xorg-video-openchrome
    xserver-xorg-video-nouveau
    xserver-xorg-video-neomagic
    xserver-xorg-video-mga
    xserver-xorg-video-mach64
    xserver-xorg-video-intel
    xserver-xorg-video-i740
    xserver-xorg-video-i128
    xserver-xorg-video-fbdev
    xserver-xorg-E: Sub-process /usr/bin/dpkg returned an error code (1)

    Gracias por toda la ayuda que me puedas brindar

  7. Antes que nada, gracias y ánimo… por el blog. Quisiera plantear algunas dudas si me lo permites.

    Bueno, soy feliz usuario de linux desde hace unos 6 años. Siembre he usado Ubuntu salvo en algún “momento de crisis o desánimo” en que he probado de todo. Siempre quise usar las distros tipo debian o arch, pero se me atragantaban puesto que soy usuario veterano pero con pocas ganas de batallar con los problemas que pueda plantear una distro. Por eso las ideales para mi son las “tuneadas” por un equipo competentente como el que ha demostrado ser Canonical. Pero sus últimas decisiones no me han gustado y el rumbo que están tomando tampoco… así que estoy considerando otras opciones.

    Linux Mint siempre la deseché porque estaba basada en Ubuntu y… ¿para qué usar un dervado si puedo usar el original?. Pero ahora que sale una versión debian…. ¡es ideal para mi!. Pero tengo dudas. La he probado como LiveDVD y aparentemente todo funciona. El software que incluye, alguno me gusta y otro no y creo que podré instalar todo lo que uso en Ubuntu. Mis dudas son:

    1.- En Ubuntu uso alguna PPA, ¿lo podré hacer en LMDE?
    2.- Aunque me gusta el escritorio “gnome clásico” entiendo que la evolución es hacia Gnome 3 y su shell, que me gusta y quiero acostumbrarme lo antes posible. ¿Puedo instalar Gnome 3 en LMDE sin problemas? ¿cómo?. Ya se que no está aún muy pulido, pero lo he usado en la última beta de Ubuntu y Fedora y funcionaban muy bien.
    3.- Una cuestión estética. Los iconos en Gnome 3 se ven muy grandes pero son de calidad. Pero al instalar ciertas aplicaciones su icono destroza la belleza del escritorio. No soy amante de los temas sino de colocar el icono que necesite, uno por uno. ¿Es posible en Gnome 3?.
    4.- LMDE es una rolling basada en Debian. Si bien el kernel va retrasado… ¿podré tener las últimas versiones de software?
    5.- Los propios de Linux Mint dicen que la versión debian es un “experimento”. ¿se quedará ahí o sin duda la seguiran mejorando?. No quisiera cambiar y luego encontrarme conque suspenden el proyecto. ¿Tienen previsto añadir Gnome 3?¿Cuándo saldrá la próxima versión del DVD?.

    Bueno, gracias de cualquier manera.

    Desde luego, incluso como LiveDVD me funciona mucho más rápido que Ubuntu abriendo rapidísimamente un mkv a 1080 y reproduciéndolo sin problemas por ejempo.

    • Saludos Jose:

      1- En Debian o en LMDE se pueden usar PPAs de Ubuntu siempre y cuando sean semejantes los paquetes.. Ejemplo, a Squeeze, le viene bien los paquetes de Lucid y algunos de Maverick, pero no de Natty.

      2- Claro que se puede añadir, usando los repositorios experimentales de Debian. Ahora mismo te escribo desde Gnome3.

      3- Estoy usando Faenza en Gnome3.

      4- Si usas siempre Testing si, aunque también puedes usar Sid y Experimental. Aunque en Testing ya está el 2.6.38.

      5- No creo que abandonen Debian, sobre todo, cuando tantos usuarios han adoptado LMDE. EL problema es, que ellos dejan los paquetes según vayan entrando a los repositorios de Debian. Ahora, no sé si incluirán Gnome3 en los repos de Mint.. Hay que esperar.

      Saludos y espero haber aclarado tus dudas.

  8. OK. Gracias por contestar. Bueno si … has resuelto alguna de mis dudas. Lo único… mira si se pueden cambiar los iconos uno por uno, sin paquetes de iconos. En Gnome 2 existía El Editor de Menús (Alacarte) que te permitía hacer un lanzador y asignarle un icono (por ejemplo para aplicaciones en java que no ibas a instalar)… pero creo que en Gnome 3 ha desaparecido y no se si es sólo temporal. Resumiendo…. ¿se puede añadir un lanzador al “dash” (¿se llama así?) de Gnome 3?.

    Gracias. Saludos.

    • Bueno, hasta la versión de Gnome3 que estoy probando en Debian, Alacarte funciona pero en el modo Fallback, que es lo que viene siendo la forma anterior de Gnome con 2 paneles.

      No se puede esperar mucho aún en personalización para con Gnome3. Para estos detalles hay que esperar un poquito aún.

      • OK. Muchas gracias. Supongo que esperaré a que salga una versión más estable/configurable (creo que la 3.2 sale para después del verano). Y disculpa lo de “mira si se pueden cambiar los iconos uno por uno…”. Ni que estuvieras a mi disposición. Ja ja ja.

        Saludos.

  9. Me puedes orientar?

    Pasa esto:

    W: GPG error: http://hadret.rootnode.net unstable Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 152FA1ABEE903351
    W: Imposible obtener http://ftp.it.debian.org/debian/dists/unstable/Release.gpg No puedo iniciar la conexión a http://ftp.it.debian.org:80 (2001:1418:13:1::5). – connect (101: La red es inaccesible) [IP: 2001:1418:13:1::5 80]

    W: Imposible obtener http://ftp.it.debian.org/debian/dists/unstable/contrib/i18n/Translation-en.bz2 No puedo iniciar la conexión a http://ftp.it.debian.org:80 (2001:1418:13:1::5). – connect (101: La red es inaccesible) [IP: 2001:1418:13:1::5 80]

    W: Imposible obtener http://ftp.it.debian.org/debian/dists/unstable/contrib/i18n/Translation-es.bz2 No puedo iniciar la conexión a http://ftp.it.debian.org:80 (2001:1418:13:1::5). – connect (101: La red es inaccesible) [IP: 2001:1418:13:1::5 80]

    W: Imposible obtener http://ftp.it.debian.org/debian/dists/unstable/main/i18n/Translation-en.bz2 No puedo iniciar la conexión a http://ftp.it.debian.org:80 (2001:1418:13:1::5). – connect (101: La red es inaccesible) [IP: 2001:1418:13:1::5 80]

    W: Imposible obtener http://ftp.it.debian.org/debian/dists/unstable/main/i18n/Translation-es.bz2 No puedo iniciar la conexión a http://ftp.it.debian.org:80 (2001:1418:13:1::5). – connect (101: La red es inaccesible) [IP: 2001:1418:13:1::5 80]

    W: Imposible obtener http://ftp.it.debian.org/debian/dists/unstable/non-free/i18n/Translation-en.bz2 No puedo iniciar la conexión a http://ftp.it.debian.org:80 (2001:1418:13:1::5). – connect (101: La red es inaccesible) [IP: 2001:1418:13:1::5 80]

    W: Imposible obtener http://ftp.it.debian.org/debian/dists/unstable/non-free/i18n/Translation-es.bz2 No puedo iniciar la conexión a http://ftp.it.debian.org:80 (2001:1418:13:1::5). – connect (101: La red es inaccesible) [IP: 2001:1418:13:1::5 80]

    W: Algunos archivos de índice no se han podido descargar, se han ignorado,
    o se ha utilizado unos antiguos en su lugar.
    ______________________

    Hay alguna forma de arreglarlo al querer actualizar el sistema?

    • Me parece que tienes un grave problema con tu red (IP mal configurada o algo asi) o tu ISP te tiene bloqueado de algún modo. Llego a eso conclusión debido al error que te dá:

      No puedo iniciar la conexión a http://ftp.it.debian.org:80 (2001:1418:13:1::5). – connect (101: La red es inaccesible) [IP: 2001:1418:13:1::5 80]

  10. Leandro Minatel

    Hola maestro, muy bueno el aporte!. Soy usuario Debian para servidores y (casi un ex) Ubuntu para Desktop. Siempre me movi con LTS ya que no me gusta esto de actualizar cada 6 meses.

    Estos nuevos rumbos que esta tomando el amigo Mark (Shuttleworth) con Ubuntu no son de mi agrado, con lo que he empezado a buscar una distro desktop-oriented para reemplazar Ubuntu.

    Obviamente busco algo basado en Debian y no en otra cosa. LMDE me intereso. Mi pregunta es la siguiente: A la hora de liberar LMDE el testing era squeeze y ahora es wheezy, ¿mando el dist-upgrade de wheezy o conviene pasar por squeeze?

    Saludos y gracias por el aporte nuevamente!

    • Primero que nada gracias por pasarte. Sin dudas podrás encontrar en LMDE una excelente distribución. Si tienes buen ancho de banda, creo que lo más aconsejable será actualizar a Squeeze y posteriormente a Wheezy, aunque en teoría, si actualizas directo a Testing no debe pasar nada.

      Yo no puedo decirte a ciencia cierta porque yo lo que hago es instalarme Debian y luego añado los repos de LMDE..

      Saludos

  11. Leandro Minatel

    Bueno, segui tus consejos y salio andando, por si a alguien le interesa:
    1. Instalar LMDE (201012/201101)
    2. Modificar el sources.list y apuntar a squeeze
    3. apt-get dist-upgrade
    4. Modificar el sources.list y apuntar a testing (ahora wheezy)
    5. apt-get dist-upgrade
    6. bye bye Ubuntu…

    Gracias nuevamente!

  12. Disculpa amigo, tengo una gran duda con una actualización de ‘pulseaudio’, la actualización viene con una nueva configuración, pero no estoy seguro si mantener la configuración actual o aplicar la nueva configuración:
    ——————————————————————————————————————–
    — /etc/pulse/default.pa 2010-08-06 14:37:21.000000000 -0500
    +++ /etc/pulse/default.pa.dpkg-new 2011-07-25 17:59:00.000000000 -0500
    @@ -23,10 +23,9 @@

    ### Load something into the sample cache
    #load-sample-lazy x11-bell /usr/share/sounds/gtk-events/activate.wav
    -#load-sample-lazy pulse-hotplug /usr/share/sounds/linuxmint-login.wav
    -#load-sample-lazy pulse-coldplug /usr/share/sounds/linuxmint-login.wav
    +#load-sample-lazy pulse-hotplug /usr/share/sounds/startup3.wav
    +#load-sample-lazy pulse-coldplug /usr/share/sounds/startup3.wav
    #load-sample-lazy pulse-access /usr/share/sounds/generic.wav
    -load-sample-dir-lazy /usr/share/sounds/LinuxMint/stereo

    .fail

    @@ -40,7 +39,7 @@
    load-module module-augment-properties

    ### Load audio drivers statically (it’s probably better to not load
    -### these drivers manually, but instead use module-hal-detect –
    +### these drivers manually, but instead use module-udev-detect –
    ### see below — for doing this automatically)
    #load-module module-alsa-sink
    #load-module module-alsa-source device=hw:1,0
    @@ -109,13 +108,15 @@

    ### If autoexit on idle is enabled we want to make sure we only quit
    ### when no local session needs us anymore.
    +.ifexists module-console-kit.so
    load-module module-console-kit
    +.endif

    ### Enable positioned event sounds
    load-module module-position-event-sounds

    ### Cork music streams when a phone stream is active
    -#load-module module-cork-music-on-phone
    +load-module module-cork-music-on-phone

    # X11 modules should not be started from default.pa so that one daemon
    # can be shared by multiple sessions.
    ——————————————————————————————————————–
    Por lo que comprendo es que se cambiaran algunos sonidos, pero me inquieta la parte en la que se habla acerca del modulo ‘udev’, LMDE usa ‘hal’ ¿cierto?, ¿estaria bien aplicar esos cambios?

    (Por el momento no quiero continuar hasta recibir tu ayuda, no quiero dañar el sistema)

  13. Hola
    Hace poco pase de Ubuntu a Lmde.
    Una duda
    ¿Como hago andar el Mupen 64 en lmde?
    GRacias

  14. groso esto me sivio perfectamente ahora ya estoy convensido en pasarme a lmde

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

Únete a otros 38 seguidores

%d personas les gusta esto: